Windows way to Digital Learning……

Posts tagged ‘HAL Upgrade Required’

You must restart your system before Hyper-V Integration services can be installed. Do you want to restart now?

You must restart your system before Hyper-V Integration services can be installed. Do you want to restart now?

I was virtualizing a physical machine running ISA server 2006 by using the sysinternal tool Disk2Vhd.

VHD file was created successfully. I attach this VHD in Hyper-v running on Windows 2008 R2 SP1.

While installing Hyper-v integration services, I get the message “HAL Upgrade Required“, try to upgrade by clicking OK.

After sometime, get the message below.

You must restart your system before Hyper-V Integration services can be installed. Do you want to restart now

Even after restart it fails to install the integration services.

Resolution:

Find the boot.ini on the operating system installed drive edit the file and delete the option “Disk2Vhd Windows Server 2003 Standard” then save the file.

Now reboot the guest machine and try to install the integration services it should work like a charm.

Advertisements

Tag Cloud